Three seperate issues, unsure if linked

  1. Bug description
    [Describe what the bug is in your own words.]
    decklists wont save at all, says something along the lines of “that name already exists” and thus disappear when game is closed (yes names where in character limit), next issue occurs with updating, asks if i wish to update client, selecting yes shows update bar, update “completes” and then nothing happens, game dosent start, its just the background screen, if select no game will start up, but i think the other 2 bugs may stem from this one, i have tried restarting it multiple times, updates seem to have never happened each time i open the game, final issue occurs with test hands, after beating ai opponent game menu for rematches and the like comes up but is completly unresponsive, causing the game to need to be closed

  2. Bug reproduction steps
    unsure if these are recreateable on another copy, but just in case
    bug 1: attempt to save new decklist, deck will still show up after exiting editor but will disappear once game is closed
    bug 2: open game, select yes to prompt asking to update, watch
    bug 3: open test hands, beat ai opponent, try interacting with menu
    [Write the exact steps to reproduce the bug. Provide a replay code if you can. You can attach replay codes, or use a pastebin link or you can even use a spoiler tag using]


    your replay code

  3. Screenshot OR error code

  4. Expected behavior
    [Tell us what should have happened when the bug occurred.]
    bug 1: deck should save and appear in deck editor when booted up
    bug 2: game should have opened after update finished or after closing and booting back up after update finished
    bug 3: menu should work after beating ai opponent

  5. What OS are you using
    [Windows-10 / Linux / Android]
    windows 10

update: tried deleting and redownloading, did literally nothing

update 2: they were in fact linked, retried the installer which fixed the update and that fixed the other 2 issues, so if anyone else is having similar issues try launching the installer again might fix it idk