The most recent update broke the date filters

The new date filter fields accept dates in a different format than before, and seem to break when you try to paste dates into them, even in their new expected format.
old format: DD-MM-YYYY
new format: YYYY-MM-DD (even if it says otherwise when the field is empty)

The only way to make these fields work is by opening the new calendar menu and manually selecting a date, which is very tedious, because even the default 01-01-0001 doesn’t seem to work, so you’d have to scroll all the way back to the 90s to get all the cards.
This problem exists both in the deck builder and when hosting a game.
I’m using Windows 10.

Issue on github: The most recent update broke the date filters · Issue #21 · duelists-unite/omega-releases · GitHub

The format being used now and before are both dd-MM-yyyy on the deck editor, which is also the format that the calendar throws in there. Do you have any calendar localization setup on your system that may make it behave differentely? In the test setup it works perfectly for filtering. The calendar isnt obrigatory to use, you can always directly write the date values on the fields, but be sure to use ASCII numerical characters separated by also ASCII separators like " - " character.

When I try to paste, for example “14-03-2008” (without the quotes) into a date field in the deck manager, it give an error “Invalid data in clipboard”, but pastes it anyway. Applying the filter so doesn’t have any effect.
The same happens with “14.03.2008”, or even “2008-03-14” or “2008.03.03”, it always gives the same error and no result. Typing it out manually doesn’t give an error, but doesn’t work either.
When editing game custom properties when hosting, it doesn’t give any errors, but the dates simply don’t update in the header when I go back to the room.

The only way to make a date field work right now is to use the calendar menu, which inputs dates as “2008-03-14”, hence why I thought the format was changed, but maybe the problem is in the parsing itself.

Everything worked fine with both writing in dates and pasting on the previous version that didn’t have the calendar menu. My Windows 10 regional format setting is set to [English (United States)] and displays the date as 30-Jul-23. I tried changing it to [English (United Kingdom)], but that didn’t seem to change anything in-game. My region is set to Bulgaria, but here we also use the dd-mm-yyyy format, so that couldn’t be it.

Let me know if I can provide any more information to troubleshoot this problem.

Ill be debugging it to find the issue, should be good on next hotfix.

Some issues still persist.
-Pasting still gives “invalid data in clipboard”, but seems to have effect, even if it’s doesn’t fix its formatting (my dates are still in YYYY-MM-DD, but pasting in DD-MM-YYYY still works, although it doesn’t reformat it like it would if writing manually).
-After doing so, resetting filters visually clears the date filter (sets it to 31-12-9999), but functionally, the old filter is still in effect. The only way to clear it is to set another date.
-Writing dates in manually seems to work fine, but the reset still doesn’t.
-When hosting games everything seems to work fine now.
-I still have no idea why my date format is YYYY-MM-DD. Maybe that is the underlying root of the problem?