Stuck on a update loop

  1. Bug description
    [as a load in to play and click online it prompts me that an update is required so I select to update, once it is done it reopens and load as normal. then i click on;line again and its the same thing is prompted.]

  2. Bug reproduction steps

    [i reinstalled twice and was met with the same issue]


    your replay code

  3. Screenshot OR error code

  4. Expected behavior
    [i should have been able to connect to the online menu right after clicking it but failed to do so.]


Can u fix it? I have the same problem :frowning:


I have the same issue!


I am having the same issue :frowning:


Okay so after turning off my laptop and letting it sit for a few hours. I came back on, and opened it same thing happened. So what I did was close Omega. right click on the Omega shortcut > clicked on open file location > then selected update.exe file. Ran it. it did the download and after that it automatically opened YGO Omega and boom it worked. Not certain if this will be effective with everyone. Attempt on redownloading the install file first then follow the steps.


check what i just wrote

1 Like

This worked for me, thanks for the tip!

This works! Thank you!

That worked! thanks man… in my case the file name is “OmegaUpdater” in case someone else is not finding as update.exe

It workkk, thanks bro