Omega fresh install does not work

  1. Bug description
    [Describe what the bug is in your own words.]
    Omega hasn’t been updated in 2 weeks. After launching buttons did not work. Investigated and found Player.data file is missing. Tried a fresh install by uninstalling and then deleting all relevant YGO Omega files/Unity files. Fresh install has the same issue even after running OmegaUpdater.exe; there is no player.data file and it is not created on launch.
  2. Bug reproduction steps
    [Write the exact steps to reproduce the bug. Provide a replay code if you can. You can attach replay codes, or use a pastebin link or you can even use a spoiler tag using]
  1. Uninstall Omega

  2. Install Omega from installer.exe

  3. Launch Omega, notice buttons do not work

  4. Launch OmegaUpdater.exe, then Omega is started. Online does not work, deck edit shows 9999/9999 decks used, with the same icon, however none of them can be edited. Player.data file is missing and is not generated when starting Omega.

  1. Screenshot OR error code

image

image
4. Expected behavior
[Tell us what should have happened when the bug occurred.]

When launching Omega, a player.data file should be created in the location shown above: \Users…\AppData\LocalLow\Duelists Unite\YGO Omega
Online should be available. Decks should not be capped and have random icons.

  1. If you have issues with connecting, please attach your Player.log file (Find this file in %userprofile%/AppData/LocalLow/Duelists Unite/YGO Omega/Player.log. Skip this step if you don’t have connection issues)

I do have issues connecting to online, while others are clearly searching for duels:

Player-log.txt:

Loading player data from C:/YGO Omega/YGO Omega_Data/data.unity3d
Initialize engine version: 2020.1.6f1 (fc477ca6df10)
[Subsystems] Discovering subsystems at path C:/YGO Omega/YGO Omega_Data/UnitySubsystems
GfxDevice: creating device client; threaded=1
Direct3D:
Version: Direct3D 11.0 [level 11.1]
Renderer: AMD Radeon™ Vega 8 Graphics (ID=0x15dd)
Vendor: (null)
VRAM: 3087 MB
Driver: 25.20.15030.4
D3D11 device created for Microsoft Media Foundation video decoding.
Initializing input.

New input system (experimental) initialized
XInput1_3.dll not found. Trying XInput9_1_0.dll instead…
Input initialized.

Initialized touch support.

UnloadTime: 0.980800 ms
<color=#0099bc>DOTWEEN ► Couldn’t load Modules system
UnityEngine.DebugLogHandler:LogFormat(LogType, Object, String, Object[])
UnityEngine.Logger:Log(LogType, Object)
UnityEngine.Debug:LogError(Object)
DG.Tweening.Core.DOTweenComponent:Awake()

(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 35)

Unloading 5 Unused Serialized files (Serialized files now loaded: 0)

Unloading 3 unused Assets to reduce memory usage. Loaded Objects now: 932.
Total: 3.321000 ms (FindLiveObjects: 0.431500 ms CreateObjectMapping: 0.159600 ms MarkObjects: 2.708500 ms DeleteObjects: 0.020300 ms)

Curl error 7: Failed to connect to chocolatecannoli.com port 443: Timed out

(Filename: Line: 815)

CDN Network not reachable
UnityEngine.DebugLogHandler:LogFormat(LogType, Object, String, Object[])
UnityEngine.Logger:Log(LogType, Object)
UnityEngine.Debug:Log(Object)
e:MoveNext()
UnityEngine.SetupCoroutine:InvokeMoveNext(IEnumerator, IntPtr)

(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 35)

Unable to open archive file: C:/Users/T945004/AppData/Local/Temp/Duelists Unite/YGO Omega/GameData
(Filename: Line: 588)

Failed to read data for the AssetBundle ‘YGO Omega\GameData’.
(Filename: Line: 449)

Unloading 3 Unused Serialized files (Serialized files now loaded: 0)
NullReferenceException: Object reference not set to an instance of an object.
at fo+d.MoveNext () [0x00000] in <00000000000000000000000000000000>:0
at UnityEngine.SetupCoroutine.InvokeMoveNext (System.Collections.IEnumerator enumerator, System.IntPtr returnValueAddress) [0x00000] in <00000000000000000000000000000000>:0

(Filename: currently not available on il2cpp Line: -1)

Unloading 26 unused Assets to reduce memory usage. Loaded Objects now: 6538.
Total: 70.761900 ms (FindLiveObjects: 1.612500 ms CreateObjectMapping: 0.543100 ms MarkObjects: 68.514600 ms DeleteObjects: 0.089700 ms)

Unloading 0 Unused Serialized files (Serialized files now loaded: 0)

Unloading 0 unused Assets to reduce memory usage. Loaded Objects now: 6538.
Total: 74.863800 ms (FindLiveObjects: 1.258200 ms CreateObjectMapping: 1.265500 ms MarkObjects: 72.317700 ms DeleteObjects: 0.021300 ms)

Unloading 2 Unused Serialized files (Serialized files now loaded: 0)

Unloading 4 unused Assets to reduce memory usage. Loaded Objects now: 6697.
Total: 61.134800 ms (FindLiveObjects: 1.191600 ms CreateObjectMapping: 2.578800 ms MarkObjects: 57.319700 ms DeleteObjects: 0.043600 ms)

[InterNetwork] Connection timed out
UnityEngine.DebugLogHandler:LogFormat(LogType, Object, String, Object[])
UnityEngine.Logger:Log(LogType, Object)
UnityEngine.Debug:Log(Object)
fr:cjq()
System.Func`1:Invoke()
b:byq(Object)
System.Threading.ParameterizedThreadStart:Invoke(Object)
System.Threading.QueueUserWorkItemCallback:WaitCallback_Context(Object)
System.Threading.ContextCallback:Invoke(Object)
System.Threading.ExecutionContext:RunInternal(ExecutionContext, ContextCallback, Object, Boolean)
System.Threading.QueueUserWorkItemCallback:System.Threading.IThreadPoolWorkItem.ExecuteWorkItem()
System.Threading.ThreadPoolWorkQueue:Dispatch()
System.Threading._ThreadPoolWaitCallback:PerformWaitCallback()

(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 35)

Connection failed after 1 resolve attempts with 1 valid attempts
UnityEngine.DebugLogHandler:LogFormat(LogType, Object, String, Object[])
UnityEngine.Logger:Log(LogType, Object)
UnityEngine.Debug:Log(Object)
fr:cjq()
System.Func`1:Invoke()
b:byq(Object)
System.Threading.ParameterizedThreadStart:Invoke(Object)
System.Threading.QueueUserWorkItemCallback:WaitCallback_Context(Object)
System.Threading.ContextCallback:Invoke(Object)
System.Threading.ExecutionContext:RunInternal(ExecutionContext, ContextCallback, Object, Boolean)
System.Threading.QueueUserWorkItemCallback:System.Threading.IThreadPoolWorkItem.ExecuteWorkItem()
System.Threading.ThreadPoolWorkQueue:Dispatch()
System.Threading._ThreadPoolWaitCallback:PerformWaitCallback()

(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 35)

Unloading 0 Unused Serialized files (Serialized files now loaded: 0)

Unloading 0 unused Assets to reduce memory usage. Loaded Objects now: 6697.
Total: 84.877400 ms (FindLiveObjects: 1.555400 ms CreateObjectMapping: 1.146600 ms MarkObjects: 82.157400 ms DeleteObjects: 0.016800 ms)

Unloading 0 Unused Serialized files (Serialized files now loaded: 0)

Unloading 0 unused Assets to reduce memory usage. Loaded Objects now: 6697.
Total: 87.666900 ms (FindLiveObjects: 2.047100 ms CreateObjectMapping: 1.243200 ms MarkObjects: 84.351500 ms DeleteObjects: 0.024100 ms)

Unloading 0 Unused Serialized files (Serialized files now loaded: 0)

Unloading 0 unused Assets to reduce memory usage. Loaded Objects now: 6697.
Total: 68.511400 ms (FindLiveObjects: 1.170800 ms CreateObjectMapping: 2.399400 ms MarkObjects: 64.924000 ms DeleteObjects: 0.016100 ms)

Unloading 1 Unused Serialized files (Serialized files now loaded: 0)

Unloading 12 unused Assets to reduce memory usage. Loaded Objects now: 6713.
Total: 114.797500 ms (FindLiveObjects: 2.408900 ms CreateObjectMapping: 3.181000 ms MarkObjects: 109.100700 ms DeleteObjects: 0.105500 ms)

[InterNetwork] Connection timed out
UnityEngine.DebugLogHandler:LogFormat(LogType, Object, String, Object[])
UnityEngine.Logger:Log(LogType, Object)
UnityEngine.Debug:Log(Object)
fr:cjq()
System.Func`1:Invoke()
b:byq(Object)
System.Threading.ParameterizedThreadStart:Invoke(Object)
System.Threading.QueueUserWorkItemCallback:WaitCallback_Context(Object)
System.Threading.ContextCallback:Invoke(Object)
System.Threading.ExecutionContext:RunInternal(ExecutionContext, ContextCallback, Object, Boolean)
System.Threading.QueueUserWorkItemCallback:System.Threading.IThreadPoolWorkItem.ExecuteWorkItem()
System.Threading.ThreadPoolWorkQueue:Dispatch()
System.Threading._ThreadPoolWaitCallback:PerformWaitCallback()

(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 35)

Connection failed after 1 resolve attempts with 1 valid attempts
UnityEngine.DebugLogHandler:LogFormat(LogType, Object, String, Object[])
UnityEngine.Logger:Log(LogType, Object)
UnityEngine.Debug:Log(Object)
fr:cjq()
System.Func`1:Invoke()
b:byq(Object)
System.Threading.ParameterizedThreadStart:Invoke(Object)
System.Threading.QueueUserWorkItemCallback:WaitCallback_Context(Object)
System.Threading.ContextCallback:Invoke(Object)
System.Threading.ExecutionContext:RunInternal(ExecutionContext, ContextCallback, Object, Boolean)
System.Threading.QueueUserWorkItemCallback:System.Threading.IThreadPoolWorkItem.ExecuteWorkItem()
System.Threading.ThreadPoolWorkQueue:Dispatch()
System.Threading._ThreadPoolWaitCallback:PerformWaitCallback()

(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 35)

Unloading 0 Unused Serialized files (Serialized files now loaded: 0)

Unloading 0 unused Assets to reduce memory usage. Loaded Objects now: 6713.
Total: 85.836700 ms (FindLiveObjects: 2.308400 ms CreateObjectMapping: 1.094200 ms MarkObjects: 82.408000 ms DeleteObjects: 0.023500 ms)

Unloading 0 Unused Serialized files (Serialized files now loaded: 0)

Unloading 0 unused Assets to reduce memory usage. Loaded Objects now: 6713.
Total: 97.127800 ms (FindLiveObjects: 1.239600 ms CreateObjectMapping: 0.446600 ms MarkObjects: 95.419900 ms DeleteObjects: 0.020500 ms)

Unloading 0 Unused Serialized files (Serialized files now loaded: 0)

Unloading 0 unused Assets to reduce memory usage. Loaded Objects now: 6713.
Total: 67.968300 ms (FindLiveObjects: 1.406700 ms CreateObjectMapping: 0.916200 ms MarkObjects: 65.630200 ms DeleteObjects: 0.014400 ms)

Setting up 2 worker threads for Enlighten.
Thread -> id: 128f8 -> priority: 1
Thread -> id: d120 -> priority: 1

Do you still have this issue? We’ve seen that this happens when people move the game away from C:.

I no longer have this issue. My firewall was blocking the application from updating. Works fine now, application was installed in C:.

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.