Client crashes while hosting a game

  1. Bug description
    Game client crashes when I try to host a duel. The duel itself doesn’t crash the game, i can spectate games with no issue. Also, i just test it and i can join an already hosted game and play with no issues.
    Update: Now crashes every time i try to join or host a game.

  2. Bug reproduction steps
    Host a game, then crashes. The player.log file: Player_log.txt (13.7 KB)

  3. Screenshot OR error code
    There are no error codes in the console, it just crashes right there.

  4. Expected behavior
    Being able to pick a bot, or just play hosting the duel myself

  5. What OS are you using
    Linux (Manjaro KDE, 64bit), it happens using the Launcher and using the zip without a launcher, haven’t tried yet compiling the source code myself.

Edit: Just checked the discord, i’ll be using the discord browser then

1 Like

I have the same issue, but I can’t even join a hosted game. When the join game screen appears (just as Nanda’s screenshot) the game crashes.

Below is the console output, if it helps:

./YGO\ Omega.x86_64

[UnityMemory] Configuration Parameters - Can be set up in boot.config
Loading in SingleInstance mode
Aborted (core dumped)

I stopped using the linux version, but suddenly the Windows version with Wine/Proton stopped working for me, tried again the linux version and… now i have the same problem as you, the game crashes whenever i try to host or join a game.

Hopefully someone will see this, I really like this simulator but it’s unplayable for me.

1 Like

Recently I found this post and it works for me, but note that it’s a workaround. Don’t know if this works for your Windows version, but give it a shot with the native Linux one. They really need to solve this issue in the next releases.

how do you fix this situation in linux. I’ll be grateful if you can help