Bluetooth headphone Bug

  1. Bug description
    When entering a duel room/lobby (the menu where you press “ready” and stuff), connected bluetooth headphones will completely stop working for all applications untill you leave the duel.

  2. Bug reproduction steps
    Have a window that plays sound open (i assume it also happens without that but this makes the bug more “visable”) then join a duel room.

  3. Screenshot OR error code

  4. Expected behavior
    [Tell us what should have happened when the bug occurred.]

  5. If you have issues with connecting, please attach your Player.log file (Find this file in %userprofile%/AppData/LocalLow/Duelists Unite/YGO Omega/Player.log. Skip this step if you don’t have connection issues)

Kunogi used bluetooth headphones and it worked just fine. Could be related specifically to your driver or your own bluetooth device that didn’t get paired with your machine. Because in the end, the game’s audio is being outputted by your pc. Try to see if they work with other games.

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.

From what I understand the problem is with the way Windows handles Bluetooth headphones with a microphone specifically. This should therefore be a problem with all Bluetooth headsets with a mic. Windows can’t handle high quality bluetooth sound while the microphone is enabled. Therefore if you connect a Bluetooth headset you will have 2 devices/profiles: One has low quality audio and can therefore also be used with mic, the other one has high quality bluetooth audio but you can’t use a mic. Normally I would use the high quality profile and have the other profile set as the default device for Discord. I have no issues with other programs. The problem with Omega now is that when you join a game in the lobby Omega disables the high quality device completely which results in everything being muted. Now when I switch my audio to the low quality one it works fine. Also disabling the low quality device completely fixes this issue. If I only have the high quality device enabled this basically turns my headset into headphones meaning I can’t use the mic at all and have to manually enable and disable devices every time I want to use my mic. While this is a decent workaround it would be nice to be able to use my bluetooth headset normally without disabling and enabling the mic. It seems like for some reason Omega is turning on the mic but not switching to the low quality audio device which causes the high quality audio device to stop working.

The workaround is: Go to control panel->Hardware and Sound->Sound and disable the device called hands-free AG Audio under playback and recording. This will cause your microphone to stop working, so if you need to use it you have to reenable those devices